Plone Unified Installer - Error - Python 2.7

Oscar Brito

Having problems with Plone installation:

On Ubuntu 11.10 the default python is 2.7. You must install 2.6 for Plone 4.1.2 to installation work.

"Its an issue with the Python disutils and the new multilib setup of natty. I ran into the same issue trying to get sqlite support in Python built from source."

Easy Solution:

> sudo apt-get install python2.6
> sudo apt-get install python2.6-dev

> sudo ./install.sh --with-python=/usr/bin/python2.6 standalone

Reference:
http://dev.plone.org/ticket/12295

Hack Solution
Another approach is patch the python src available in Plone packages.

http://stackoverflow.com/questions/6030876/plone-4-0-5-unified-installer-failing-on-ubuntu-11-04-natty-with-zip-zlib-erro#answer-6045862



Visit www.divhide.com for more informations, contacts and news about Web Development.
See other blog posts at blog.divhide.com.



Divhide purpose is to follow the HTML5 movement and contribute with applications which prove the quality of technology.


Feel free to contact divhide.